WWW Watch

Chrome が SPDY のサポートを 5月15日にやめて HTTP/2 に完全移行するらしい

Google が、Chrome における SPDY のサポート終了と HTTP/2 への移行に関して、2016年 5月 15日という具体的な日付を出して公式に発表しました。同時に NPN TLS 拡張のサポートも終了し、ALPN TLS 拡張に一本化されるとのこと。

Google Chrome去年の 2月の時点ですでに 「2016年の早い時期には・・・」 と発表されていましたので (下記記事参考)、特に目新しいというか、急な発表ではないのですが、

Google Chrome における SPDY のサポート終了と HTTP/2 への移行に関して、2016年 5月 15日という具体的な日付を出して公式に発表しました。

Over 25% of resources in Chrome are currently served over HTTP/2, compared to less than 5% over SPDY. Based on such strong adoption, starting on May 15th -- the anniversary of the HTTP/2 RFC -- Chrome will no longer support SPDY.

Transitioning from SPDY to HTTP/2 : Chromium Blog から引用

「すでに Chrome が扱うリソースの 25% は HTTP/2 で提供されていて、SPDY の 5% と比べても多いんで、5月 15日 ―これは HTTP/2 の RFC (RFC 7540 - Hypertext Transfer Protocol Version 2 (HTTP/2)) が公開された記念日だよ― には SPDY のサポートを終了して HTTP/2 のみをサポートするように変更するよ」 とのこと。

※ RFC 7540 が公開されたのは 2015年 5月 14日です。5月 15日に Chrome を起動したときにはもう SPDY はサポートされてないよ的な言い回しですね。

Servers that do not support HTTP/2 by that time will serve Chrome requests over HTTP/1.1, providing the exact same features to users without the enhanced performance of HTTP/2.

Transitioning from SPDY to HTTP/2 : Chromium Blog から引用

「この日までに、SPDY のみで HTTP/2 をサポートしていないサーバは、HTTP/1.1 でしか接続できなくなるよ」 とのことで、気になる方はお早めにという感じですが、そもそもこの辺を気にする人はすでに HTTP/2 に移行している気もしますので今更感ありますけども。

TLS-NPN もサポート終了、TLS-ALPN に一本化

At the same time, Chrome will stop supporting the TLS protocol extension NPN, which allows servers to negotiate SPDY and HTTP/2 connections with clients. NPN has been superseded by the TLS extension ALPN, published by the IETF in 2014. ALPN is already used 99% of the time to negotiate HTTP/2 with Chrome, and the remaining servers can gain ALPN support by upgrading their SSL library.

Transitioning from SPDY to HTTP/2 : Chromium Blog から引用

SPDY のサポート終了と同時に、TLS 拡張である NPN もサポート終了。ALPN のみのサポートとなります。これも去年 2月の時点でアナウンスされていました。

「HTTP/2 ネゴシエーションの 99% が ALPN で行われていることからもわかるとおり、NPN はすでに ALPN に取って代わられている。現状で ALPN をサポートしていないサーバに関しても、サーバ管理者が SSL ライブラリをアップデートすれば簡単に済む話なので (例えば、OpenSSL は 1.0.2 以降で ALPN に対応しています)、もうええやろ」 とのこと。

といいつつ、この Blog をホストしているサーバはまだ Apache + mod_spdy って組み合わせから抜け出していないんですけども (Apache 2.2 系 → 2.4 系へのアップデートが面倒くさすぎてやってない) 、そろそろ重い腰を上げて HTTP/2 への移行をしようかなと思いました。

関連エントリー

Recent Entry

全ての記事一覧を見る

Hot Entry

逆引きおすすめエントリー