WWW Watch

Flickr が IE7 と Firefox 3.6 をサポート対象外に

Flickr が新年早々に今年の取り組みとして新しい写真編集機能の提供開始や、今後提供される新機能について IE7 と Firefox 3.6 をサポート対象外にすることなどを案内しています。

FlickrInstagram やら、その他ソーシャル系サービスに埋もれて忘れ去られた感のある Yahoo! が提供する写真共有サービス Flickr ですが、個人的には有料アカウント持って写真投稿に関してメインで使ってたりします

その Flickr が新年早々に今年の取り組みとして新しい写真編集機能の提供開始 (元々採用していた Picnik からの移行)、「Photo Session」 や 「FlickrClock」、「FlickrAuth」 といった一部古く、あまり使われていない機能の提供終了などを発表していますが、その中で、今後提供される新機能においては IE7 と Firefox 3.6 をサポート対象とせず、両ブラウザで Flickr にアクセスすると、新しいブラウザへの移行の呼びかけとダウンロードリンクを表示するようになるよと案内しています。

Start the New Year Fresh! : Flickr Blog

Internet Explorer 7 and Firefox 3.6

For both of the browsers we are seeing a very small percentage of people using them and as of today people with those browsers will see an "update" message to encourage the download of the latest browser versions. This does not mean that IE7 and Firefox 3.6 users will experience problems using the site today, but the features and experiences that we will be releasing this year may not be supported on these browsers. For many reasons, foremost security, we encourage everyone to use the latest browser version on their devices.

Start the New Year Fresh! : Flickr Blog から引用

「今すぐ両ブラウザで Flickr が使えなくなるわけではないですよ」 っていうのと、さらに、「今後リリースされる新機能でサポートされない可能性があるよ」 っていう書き方ですので、いきなり IE7 などで Flickr サイトが使えなくなるわけではないようですが、特にこの 2つの旧式ブラウザを使い続ける理由も恐らくはないと思いますので、セキュリティの観点からも早いこと最新のブラウザにバージョンアップしてしまいましょう。

先日、米国で IE6 のシェアが 1% を切ったという話題を取り上げましたが、IE6 はその最新版だった時期の長さなどから、社内システム等の関係で新バージョンに移行できないという企業ユーザーさんなどが多く、よく問題になります。しかし一旦そこから抜け出せば、もうあとは最新版の IE を使っても OK っていう状況がほとんどだと思います。そんな関係で IE7 のシェアは元々 IE6 よりも低かったりする変な状況になっていたりするんですよね。ま、そのおかげで影響を受ける人は少ないとは思いますが。

ちなみに、Google は去年 8月の時点で、(Gmail や Google Docs などで) 以降は各ブラウザの最新版とその 1つ前のバージョンのみサポートするよと発表してたりします。なので IE で言えば、現行バージョンの IE9 と、1つ前の IE8 だけサポートするという形になりますので、すでに IE7 はサポート対象から外れています。Firefox はもうバージョンいくつか忘れるくらい高速リリースのおかげで進んじゃってますので 3.6 とか当然ながらサポート対象外ですね。

For this reason, soon Google Apps will only support modern browsers. Beginning August 1st, we'll support the current and prior major release of Chrome, Firefox, Internet Explorer and Safari on a rolling basis. Each time a new version is released, we'll begin supporting the update and stop supporting the third-oldest version.

Our plans to support modern browsers across Google Apps : Docs Blog から引用

Facebook も特定のブラウザをサポート対象外にするよと明言した公式なリリースはちょっと記憶 (単に調べてない…) にないのですが、サポートページではそれぞれのブラウザの最新版を使えと書いていますし、

Twitter も IE6 でアクセスするとモバイル版に強制的にリダイレクトされたり、IE7 では モバイル版には飛ばされないものの最新の UI は使えず、旧デザインでの表示になるなど、基本的にはすでにサポートしていない状態といっていいでしょう。

ということで、Flickr は大手 Web サービスでは IE7 や Firefox 3.6 をサポート対象外にするのが遅かった部類に入るんですね。ま、Flickr 自体、ここ最近はリニューアルや新機能のリリースとかしていませんでしたし、基本的には写真をアップロードして表示するだけのサービス (とかいうと失礼か…) なのでそんなにブラウザに厳しくなかったっていうのもあるのかもしれませんね。

関連エントリー

Recent Entry

全ての記事一覧を見る

Hot Entry

逆引きおすすめエントリー